Ãàðÿ÷èå êëàâèøè

Список "горячих клавиш"
(в соответствии с версией MixW2.06)

Клавиша Pause/Break - переключает программу на передачу и прием.
Esc - прерывание передачи.
Scrol Lock - фиксация частоты приема на спектрографе, повторное нажатие разблокирует фиксацию частоту.

С клавишей Alt используются:

Alt +A – Start auto CQ – вызывается окно для подтверждения/отказа начала автовызова “CQ”
Alt +D – Edit QSO – редактирование записи о связи в журнале/ввод данных о связи вручную
Alt+E – Pull down menu “Edit” – раскрывается меню «Редактирование»
Alt +F – Jump to CAT Fq – переход в окно индикации частоты трансивера
Alt+H – Help – вызов меню файла помощи
Alt+I – Pull down menu “File” – раскрывается меню «Файл»
Alt+K – Search Result in Log – окно результатов поиска по журналу связей
Alt+M – Pull down menu “Mode” – раскрывается меню «Вид работы»
Alt+O – Clear QSO Data – очищает данные в строке ввода QSO
Alt+P – Pull down menu “Options”- раскрывается меню «Опции»
Alt+Q – Dialog box :DXCluster” – вызывается окно DX-кластера
Alt+R – Search in logfile – диалоговое окно для поиска в файле журнала QSO по заданным критериям
Alt+S – Save QSO data – сохраняет данные в MixW2.log, введенные в строку ввода QSO
Alt+T – TNC - вызов окна для установок TNC
Alt+V – Pull down menu “View” - раскрывается меню «Вид»
Alt+U – Pull down menu “Configure” – раскрывается меню «Конфигурирование»
Alt+W – Changing Spectrum form – изменение формы спектрума: водопад/линейная
Alt+ <--- - изменяет частоту настройки на 1 Гц вниз
Alt+ ---> - изменяет частоту настройки на 1 Гц вверх
Ctrl+<--- - изменяет частоту настройки на 10 Гц вниз
Ctrl+ ---> - изменяет частоту настройки на 10 Гц вверх

С клавишей Ctrl используются:

Ctrl+A - Edit select All – выделение всего текста в текущем окне
Ctrl+С - Edit "Copy" – копирование выделенного текста
Ctrl+P - Print (Cursor in RX window) – печать содержимого в приемном окне
Ctrl+S - Swap windows – смена местами частот основного и дополнительного приемных окон
Ctrl+X – Edit Cut – вырезка при редактировании
Ctrl+Z – Edit Undo – отмена последней операции

Использование компьютерной мыши в MixW

Кроме обычных стандартных функций мыши (разворачивание меню, изменение размеров окон, выделение, копирование, удаление и т.д.) в программе заложена возможность использования дополнительных.

Так, например, двойной клик левой кнопкой в поле времени в строке ввода журнала связей - обновляет показания времени.
Двойной (или одинарный, зависит от включенной опции) клик на позывном, имени в приемном окне - вставляет эти данные в соответствующие поля строки ввода журнала связей.
Клик и удержание на кнопке [image] с левой стороны - изменяет частоту гетеродина трансивера в сторону уменьшения. С правой стороны - увеличивает ее. Причем, удаление курсора вправо и влево от центра кнопки увеличивает скорость изменения частоты.
Клик в средине передаваемого текста в передающем окне, приостанавливает передачу (для редактирования или отмены дальнейшей передачи текста, который стоит после курсора).
Ctrl+правый клик на маркере в области спектрографа - удаляет ранее установленный маркер.

Ctrl+правый клик на сигнале в области спектрографа – создает второе приемное окно. Если оно уже создано, при удержании Ctrl – на нижней линии спектрума появляется белый треугольник и происходит переключение частоты приема на место нового клика.
Правый клик в области спектрографа - выводит подменю для установок.
Правый клик в области приемного окна - выводит подменю для выполнения стандартных операций Windows по редактированию: Очистить, Копировать, Вырезать, Вставить.
Правый клик в области строки состояния - выводит подменю для выполнения указанных операций на включение/выключение.
Правый клик на Mode в строке состояния – разворачивает меню выбора вида работы и установок. Правый клик с удержанием Ctrl на Bookmark (Закладке) на спектрографе - выключает данный маркер
Правый клик на функциональных клавишах с макрокомандами - выводит диалоговое окно для редактирования данной кнопки.

Функциональные клавиши

F1..F12; Ctrl F1..F12; Shift F1..F12; Ctrl+Shift+F12; Grey Ins, Grey Plus - 50 Macros – функциональные клавиши для наборов макрокоманд. Всего 50 клавиш макрокоманд.

Каналы памяти

CTRL+1...CTRL+0 (запись) и Alt+1...Alt+0 (воспроизведение) - запись в память и воспроизведение частоты приема, вида работы и настроек. Цифры набирать только на основном блоке клавиатуры (не на цифровом!). Использование Ctrl+Shift+1...Ctrl+Shift+0 and Alt+Shift+1...Alt+Shift+0 – дает дополнительно еще 10 каналов памяти.

Начиная с версии 2.06 через меню Option/Memory можно открыть окно каналов памяти:

Здесь можно просмотреть все записи каналов памяти, записать в нужный канал, выбрав соответствующую строку и нажав кнопку Memory Write. Или считать данные с выбранного канала, нажав кнопку Memory Read.


MacrosCommand

Макрокоманды MixW и их использование:
(в соответствии с версией MixW2.06)

Особенностью использования макрокоманд программы Mixw 2 является то, что их не надо набирать, строго соблюдая синтаксис. Достаточно открыть соответствующее диалоговое окно и из предложенного списка выбрать, путем переноса в окно исполнения, нужную макрокоманду. На функциональной клавише можно сделать свою надпись.

Макрокоманды для исполнения вызываются нажатием левой кнопки мыши на соответствующей запрограммированной клавише в окне Control bar или функциональной клавише на клавиатуре. А редактируются - путем нажатия на соответствующей кнопке правым кликом мыши. В появившемся окне Edit user macro, выбираем раздел из раскрывающегося меню Subset, отмечаем маркером нужную макрокоманду и переносим ее кнопкой [<<] (или двойным щелчком мыши) в левое окно "Text". Таким образом можно легко сделать необходимый набор команд.

Ниже представлен список макрокоманд в том порядке, в котором они изложены в программе:

"Text Macros" - Текстовые макрокоманды

<MYCALL> - вставляет позывной в соответствии с данными, внесенными в Personal Data
<MYNAME> - вставляет имя в соответствии с данными, внесенными в Personal Data
<MYQTH> - вставляет QTH в соответствии с данными, внесенными в Personal Data
<CALL> - вставляет позывной корреспондента, введенный в строку ввода урнала связей
<NAME> - вставляет имя корреспондента, введенное в строку ввода журнала. Если имя отсутствует - автоматически вставляется аббревиатура "ОМ" (Old Man)
<QTH> - вставляет QTH корреспондента, введенный в строку ввода журнала. Если поле пустое - вставляется наименование страны корреспондента
<NOTES> - вставляет в поле примечание строки ввода данных
<RSTR> - рапорт, полученный от корреспондента
<RSTS> - рапорт, переданный корреспонденту
<NRR> - номер, принятый от корреспондента
<NRS> - ваш номер для передачи корреспонденту
<CWID> - передает в эфир идентификатор кодом Морзе (если активизировано в установках Personal Data)
<CR> - возврат каретки (перенос влево на новую строку)
<LF> - вставляет чистую (пустую) строку
<CRLF> - одновременно возвращает каретку и вставляет чистую (пустую) строку
<CTRL-x> - включает команду, состоящую из клавиши Ctrl и соответствующей буквы
<VER> - вставляет номер версии MixW
<DATE> - вставляет текущую дату, взятую из строки состояния MixW
<TIME> - вставляет текущее время, взятое из строки состояния MixW
<LOCALTIME> - вставляет текущее местное время
<STARTTIME> - вставляет время начала связи
<FIXSTARTTIME> текущее время начала связи
<CTIME> - вставляет время для соревнований в формате ЧЧ:ММ
<FILE> - вставляет содержимое файла, выбранного в окне меню File/Send File
<FILE:filename> - вставляет содержимое файла, имя которого указано после двоеточия
<TEXTFILE> - вставляет текст файла, имя которого выбрано в диалоговом окне
<TEXTFILE:filename> - вставляет текст файла, имя которого указано после двоеточия
<RANDOM:filenam> - вставляет случайную строку из указанного файла. Сделано для иммитации непосредственного печатания
<INIFILE:file,section,name)> - вставляет данные из файла mixw2.ini
<GA> - вставляет приветствие в виде GM (good morning), GA (good afternoon), GE (good evening) в сокращенном виде в зависимости от позывного и его расположения во временнОм поясе
<GAL> - вставляет приветствие в виде Good morning, Good afternoon, Good evening в полном виде в зависимости от позывного и его расположения во временнОм поясе
<MODE> - печатает текущий вид работы
<MHZ> - печатает текущую частоту в МГц
<MHZ:n> - печатает текущую частоту в МГц с числом разрядов n после запятой
<KHZ> - печатает текущую частоту в кГц
<KHZ:n> - печатает текущую частоту в кГц с числом разрядов n после запятой

"Programm Control" - команды управления

<TX> - включает программу на передачу
<RX> - переключает программу из режима передачи в режим приема
<RXANDCLEAR> - переключает программу из режима передачи в режим приема и очищает буфер передачи
<TXTOGGLE> - производит переключение между передачей (TX) и приемом (RX)
<MODE:mode> - установка нового вида связи (например, чтобы установить вид RTTY, необходимо записать как <MODE:RTTY>
<MODEADD:mode> - вызывает определенный командой дополнительный режим работы вне программы MixW.
<MODE TNC:mode> - устанавливает режим TNC-контролера
<CLEARWINDOW> - очищает текущее окно
<CLEARTXWINDOW> - очищает окно передачи
<CLEARRXWINDOW> - очищает окно приема
<SAVEQSO> - сохранение данных, введенных в строке ввода журнала проведенных QSO
<CLEARQSO> - очищает данные, введенные в строку ввода журнала проведенных QSO
<EXEC:command> - запуск на исполнение указанной команды
<ASSCRIPT> - запуск на исполнение указанного сценария
<SCRIPT:filename> запуск на исполнение указанного сценария из файла
<TNCSCRIPT:filename> запуск на исполнение указанного сценария из файла для второго TNC-контролера
<SHOW:name> - включает указанную панель инструментов из меню View (Control Bar, Log Bar и др.)
<HIDE:name> - выключает указанную панель инструментов
<WAVE:file_name> - воспроизведение указанного *.WAV-файла (функция голосового вызова)
<STARTRECORD> - стартует запись сигнала стандартными средствами Windows
<STARTRECORD:file_name> - стартует запись сигнала стандартными средствами Windows с указанием наименования файла
<STOPRECORD> - останавливает запись сигнала
<FILTER:name> - включает указанный цифровой фильтр (DSP) [None, Pass, Notch, Noise]
<REPLAY> - воспроизводит записанную историю звуковой частоты сигнала
<REPLAY:n> - воспроизводит записанную историю звуковой частоты с продолжительностью, указанной в секундах
<SNAP NOW> - включает захват точки настройки
<SEEKLEFT> - инициирует поиск станций влево по индикатору-спектрографу
<SEEKRIGHT> - инициирует поиск станций вправо по индикатору-спектрографу
<OUTPUTVOLUME> and <INPUTVOLUME> - вызывает стандартные средства Windows для установок уровней звуковой карты по входу и выходу
<TUNE> - стартует тональный сигнал настройки
<STARTSCAN> - включает функцию сканирования частоты
<STOPSCAN> - выключает сканирование частоты
<LASTCALL> - «захватывает» последний из позывных, появляющихся в приемном окне
<GRABCALL> - «захватывает» позывной из приемного RX-окна и вставляет его в строку ввода данных журнала
<STOP> and <ESCAPE> - равносильно значению нажатой кнопки Escape (останов)
<WORDMODE:x> - режим "целое слово", где х=1 (Вкл.), х=0 (Выкл.)
<CAPITALSONLY:x> - прописные буквы, где х=1 (Вкл.), х=0 (Выкл.)

"Frequency control" - Управление частотой

<FQ:fq_in_kHZ> - устанавливает частоту трансивера, указанную в кГц
<ZFQ:fq_in_kHz> - установка первоначальной частоты трансивера в килогерцах
<AUDIOFQ:fq_in_Hz> - установка звуковой частоты в герцах (радиочастота не изменяется )
<JUMPTOTXFQ> - частота приема переходит на частоту передачи
<ALIGN:fq_in_Hz> - установка (смещение) звуковой и радиочастоты в герцах с сохранением настройки на корреспондента
<SPZOOM:n> (n=0.5,1,2,3 или 4) устанавливает масштаб спектрума
<SPSHIFT:fq_in_Hz> - сдвиг частоты спектрума
<BOOKMARK> - включает/выключает маркеры на спектрографе
<BMERASE> - стирание всех маркеров вокруг текущей частоты передачи (полезно в AutoCQ)
<MEMR:n> - чтение из канал памяти, где n=1...20
<MEMW:n> - запись в канал памяти, где n=1...20
<CATCMD:text_command> - посылает указанную текстовую команду через САТ-систему на трансивер
<CATCMDHEX:hext_command> - посылает указанную команду в Hex-кодах через САТ-систему на трансивер
<CATWAIT:ms> - задержка на срабатывание для САТ-системы в миллисекундах
<CATCMDDDE:text_command> - направить текст посредством DDE-метода

"Auto CQ" - Автоматический вызов

<AUTOCQ> - инициализирует начало работы автоматического вызова, установки которого сделаны в меню Options | AutoCQ
<ACQ> - пауза и возобновлене функции Автовызова
<ASAUTOCQ> - назначает текущую макрокоманду как текст AutoCQ
<ACQDELAY> - время задержки включения функции автовызова
<ALARM:string> - подает звуковой сигнал, когда встречается указанный символ в окне приема

"Macros" - Макрос

<MACROS:filename> - загружает макрокоманды соответствующего файла, которые будут использованы как макросы по умолчанию (вместо MixMacros.mc)
<MODEMACROS:filename> - загружает макрокоманды соответствующего файла для конкретного режима работы, которые заранее подготовлены для этого вида (RTTY, PSK31, CW и т.д.)
<EDITMACRO:name> - редактирование макрокоманды с соответствующим именем посредством вызова диалогового окна для редактирования пользователем
<ONQSOBEFORE:name> - запускает соответствующую макрокоманду при индикации "QSO before"
<HIDETEXT> - не показывает макрокоманды в передающем окне
<SHOWTEXT> - показывает макрокоманды в передающем окне (как обычно)
<QSOCMNDDDE:command> - команда динамического обмена данными (DDE) для внешних программ

"Mode settings" - установки режимов работы

<SQUELCH> - переключает шумоподавитель squelch- "Sq"
<SQUELCHON> - включает шумоподавитель squelch- "Sq"
<SQUELCHOFF> - выключает шумоподавитель squelch- "Sq"
<AFC> - переключает автоматическую подстройку частоты - "AFC"
<AFCON> - включает автоматическую подстройку частоты - "AFC"
<AFCOFF> - выключает автоматическую подстройку частоты - "AFC"
<SNAP> - переключает Snap
<SNAPON> - включает Snap
<SNAPOFF> - выключает Snap
<INV>, <INVON>,<INVOFF> - для быстрого изменения состояния инверсии: переключить/включить/выключить
<LOCKTX> - блокирует частоту передачи
<UNLOCKTX> - разблокирует частоту передачи
<LOCKTXTOGGLE> - переключает блокировку частоты передачи
<MODESETTINGS> - открывает диалоговое окно параметров настройки для активного режима
<THRESHOLD> - вызывает диалоговое окно установок шумоподавителя RTTY -макрокоманды

Макрокоманды для "RTTY":

<SHIFT:shift_in_Hz> - установка частоты сдвига (shift) в герцах для данного режима 170, 183, 200...
<BAUDRATE:baudrate> - установка скорости передачи в бодах для RTTY
<LETTERS> - переключает на печатание большими буквами в RTTY режиме
<NUMBERS> - переход на печатание цифрами

Макрокоманды для "SSTV":

<FONTSIZE:n> - установка размера шрифта, например: <FONTSIZE:26>
<FONTFACE:name> - установка типа шрифта, например: <FONTFACE:Arial> - шрифт Arial
<FONTBOLD:n> - установка жирного шрифта
<FONTITALIC:n> - установка шрифта курсивом, типа ITALIC, например: <FONTITALIC:0>
<LOADPICTURE:file_name> -- загружает картинку с указанным именем файла вместе с верхним заголовком. Если на месте имени файла будет указана директория (папка) - загружает случайную картинку из этой директории (папки)
<LOADPICTUREONLY:file_name> - загружает картинку с указанным именем файла без верхнего заголовка
<PUTHEADER:file_name> - вставляет файл с заголовком для окна передачи

Макрокоманды для "CW"

<WPM:n> <WPM+n> <WPM-n> - абсолютное и относительное изменение скорости, где n-числовое значение слов/мин, "-" - понижение скорости, "+" - повышение.
<WPM:RX> - делает равным значение скорости передачи скорости приема в CW

Макрокоманды для поворотного устройства антенн "Rotor"

<ROTOR:SP>, <ROTOR:LP>, <ROTOR:n> - установки для приведения в действие поворотного устройства, где: SP- ShortPass - короткий путь, LP- LongPass - длинный путь и n- значение азимута в градусах.

Примечание: в последующих версиях в списке макрокоманд могут быть дополнения или изменения, связанные с развитием программы. Следите за содержанием файла History.txt в инсталляционном пакете.


SampleINI

Пример содержания файла mixw2.ini (приведен со значительными сокращениями, т.к. всего в файле около 2730 строк)

[System Info] - "информация
 о системе"
System=Microsoft Windows 2000 Pro ver 5.0 Service Pack 2 (build 2195)MixW=2.06
Data=5028lkhh317220be240
License=C7
[Tip]

TimeStamp=Thu Sep 27 00:23:12 2001
StartUp=1
FilePos=2199

[Misc] - "разное"
ShowTncDlg=0
AlwaysAddCallToBandMap=0
ScanMarkFq=1
ScanMarkTime=1
ScanDwell=3
ScanType=1
ShowBookMarks=1
WaveProcType=0
Calib=
RxLogFile=RxLog.txt
RxLogOpen=0
UseDefaultRst=1
HairlineCursor=0
StickCursor=0
FlashingTX=1
CapitalsOnly=0
WordMode=0
SimpleTxEdit1=0
UTC=1

[Font] - "установки для шрифтов"
My own call=255
New WPX=8388736
New DX=32896
New multiplier=32768
New call=8421376
QSO before=128
Log bar highlight=16777088
Log bar text=8388672
Log bar background=16777215
RX window background=16777088
RX window text=0
Keyboard window text=255
Background=13106686
RX text=0
TX text=8421631

............ вырезано..........

[CallBook] - "использование
 данных колбука"
CallBookType=3
CallBookPath=D:\callbk\
AutoSearchInCallBook=1

[View] - "вид"
DefaultFqDisplayMode=-1

[Station] - "сведения о станции и операторе"
FastCwId=1
UseCWID=0
CWID=de UT1UA k
Flags=
RegStr=
RegCall=
RegName=
Name=Victor
MyIota=
MyCounty=
MyDomain=KV
QTH=Kiev
Call=UT1UA
Lat=50.5
Long=30.5833

[Window] - "данные о
 положении и
 размерах окон"
IsMaximized=0
IsMinimized=0
SpectrumHeight=87
TxPaneHeight=81
RxPaneHeight=160
Height=565
Width=637
PosY=5
PosX=10

[Tune] - "настроечные
 данные"
AmplitudePercent=100
TuneFqHz=1000
UseFixedFq=0
[Sound]
AlwaysSoundHistory=1
FullDuplex=0

[Sound device] - "сведения о звуковой карте"
............
[Macros] - "подключение файлов макрокоманд"
m_sDefaultMacrosFilename=MixMacros.ini
RTTY-Merge=0
SSB=MixSSB.mc
SSB-Merge=1
FM=C:\Program Files\MixW\MixSSB.mc

...................

..........
(Данные могут отличаться в зависимости от индивидуальных установок и настроек)


Form_Sign

Формы сигналов
некоторых цифровых видов связи на спектрографе MixW2
(Просматривать лучше в полноэкраном режиме)

Все картинки показаны при установках спектрографа "waterfall speed=х4" и "zoom 1x", USB.

SSB

CW

PSK31 (3 станции, с разным уровнем):

FSK31:

RTTY:

45 baud, 170 Hz shift (standard) 45 baud, 23 Hz shift (MTTY)

Packet:

1200 baud, слабый сигнал 300 baud, слабый сигнал

Pactor (ARQ mode): Pactor II:

Amtor (FEC mode) MFSK16:

Throb:
1 throb/s 2 throb/s 4 throb/s

MT63 (1 kHz bandwidth):
Сильный сигнал, без QSB Слабый сигнал, QSB

Hellschreiber: Fax (FM FAX, 120 LPM, weather maps):

SSTV:


MixW DDE table

Таблица кодов полей для использования в формировании QSL-карточки DDE-методом

Entity

Server name

Topic

Item

Current state

Your call

MixW

Info

MyCall

UT1UA

Your name

MixW

Info

MyName

Victor

Your QTH

MixW

Info

MyQth

Kiev

Program name

MixW

Info

Program

MixW

MixW version

MixW

Info

Version

2.01 beta2

QSO date

MixW

QSO

Date

11-Dec-2001

QSO time

MixW

QSO

Time

21:51

Frequency, MHz

MixW

QSO

Mhz

3.7

Mode

MixW

QSO

Mode

BPSK31

Call

MixW

QSO

Call

Name

MixW

QSO

Name

QTH

MixW

QSO

Qth

Domain (state)

MixW

QSO

Domain

County

MixW

QSO

County

IOTA number

MixW

QSO

IOTA

DXCC prefix

MixW

QSO

DxccPrefix

WAZ zone

MixW

QSO

WAZ

ITU zone

MixW

QSO

ITU

Country

MixW

QSO

Country

Continent

MixW

QSO

Continent

Continent (full name)

MixW

QSO

LongCont

RST sent

MixW

QSO

RstSnt

599

RST received

MixW

QSO

RstRcv

599

QSL manager

MixW

QSO

Manager

Notes

MixW

QSO

Notes

QSO is unsaved

MixW

QSO

Changed

NO

QSO freq.

MixW

QSO

Khz

3674

Azimuth

MixW

QSO

Az

Distance

MixW

QSO

Dist

Latitude, deg.

MixW

QSO

Lat

Longitude, deg.

MixW

QSO

Long

Locator

MixW

QSO

Loc

<QSOCMDDDE:txt>

MixW

QSO

Command

Zero beat freq, kHz

MixW

CAT

Khz

3674.840

PTT state

MixW

CAT

PTT

OFF

<CATCMDDDE:txt>

MixW

CAT

Command

There are several items for the callbook information (valid when the Callbook Dialog is open):

Server name

Topic

Item

MixW

Callbook

Call

MixW

Callbook

FirstName

MixW

Callbook

LastName

MixW

Callbook

MiddleName

MixW

Callbook

Suffix

MixW

Callbook

City

MixW

Callbook

Zip

MixW

Callbook

State

MixW

Callbook

LicClass

MixW

Callbook

LicDate

MixW

Callbook

LicExp

MixW

Callbook

Longitude

MixW

Callbook

Latitude

MixW

Callbook

AreaCode

MixW

Callbook

County

MixW

Callbook

TimeZone

MixW

Callbook

DayOfBith

MixW

Callbook

DxccCountry

MixW

Callbook

PostalCountry

MixW

Callbook

PrevCall

MixW

Callbook

PrevClass

MixW

Callbook

VanityCall

MixW

Callbook

Comment

MixW

Callbook

FaxNr

MixW

Callbook

Email

MixW

Callbook

Code

MixW

Callbook

Street

MixW

Callbook

ProcessDate

MixW

Callbook

GridSquare

MixW

Callbook

TransactionType

MixW

Callbook

QslManager

MixW

Callbook

MailingAddressCountry

MixW

Callbook

Homepage

MixW

Callbook

VanityFlag